Linode Forum
Linode Community Forums
 FAQFAQ    SearchSearch    MembersMembers      Register Register 
 LoginLogin [ Anonymous ] 
Post new topic  Reply to topic
Author Message
PostPosted: Mon Mar 13, 2017 5:50 pm 
Offline
Newbie

Joined: Mon Mar 13, 2017 12:46 am
Posts: 2
I've followed the instructions in the Linode guide Install LAMP on Ubuntu 16.04.
I can access my index.html and phptest.php from within my linode CLI using the links browser (using either the IP address or the domain name, both methods work).
From external browsers, I get ERR_CONNECTION_TIMED_OUT.

When I ping my domain name from an external computer, I get a prompt ping response from the correct IP of my Linode.

I'm using Linode DNS, and in the zone for my domain name, I have A/AAAA records for both the IPv4 and IPv6 addresses. (I have no CNAME, TXT, or SRV records).
I have Reverse DNS configured for both IPv4 and IPv6 with the Target of my domain name.

Code:
systemctl status apache2
shows that apache is active (running).

What else do I need to check?
Thanks!


Top
   
PostPosted: Mon Mar 13, 2017 6:31 pm 
Offline
Junior Member
User avatar

Joined: Mon Jul 07, 2014 8:47 pm
Posts: 29
Website: https://arlen.io
Location: Earth
Twitter: arlendotio
Have you checked the firewall and allowed incoming connections to ports 80/443?

https://linode.com/docs/search?q=firewall


Top
   
PostPosted: Mon Mar 13, 2017 6:39 pm 
Offline
Newbie

Joined: Mon Mar 13, 2017 12:46 am
Posts: 2
That worked, I used ufw to configure the firewall. Thanks!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
RSS

Powered by phpBB® Forum Software © phpBB Group