Linode Forum
Linode Community Forums
 FAQFAQ    SearchSearch    MembersMembers      Register Register 
 LoginLogin [ Anonymous ] 
Post new topic  Reply to topic
Author Message
PostPosted: Mon Jul 17, 2017 8:33 am 
Offline
Newbie

Joined: Mon Jul 17, 2017 8:17 am
Posts: 2
Thanks to this guide I decided to try deploying odoo on Linode:

https://www.linode.com/docs/websites/cm ... untu-16-04

I am now using the website module here to set up a commercial site, which presumably will make e-commerce easier as it will be directly linked to my company's inventory in the odoo database. But the website only resolves to localhost:8069.

How can I modify my setup so it maps directly localhost?


Top
   
PostPosted: Fri Jul 21, 2017 9:16 am 
Offline
Senior Newbie

Joined: Thu Jun 22, 2017 1:35 am
Posts: 18
In the same article, look for "xmlrpc_port = 8069", you need to change that to 80. But this will not work if you have Apache also installed on the system, and running on port 80 (default).


Top
   
PostPosted: Fri Jul 21, 2017 10:24 am 
Offline
Newbie

Joined: Mon Jul 17, 2017 8:17 am
Posts: 2
Quote:
In the same article, look for "xmlrpc_port = 8069", you need to change that to 80. But this will not work if you have Apache also installed on the system, and running on port 80 (default).
Turns out it isn't actually that simple. But I did solve it by installing Apache and learning a bit about Apache configurations. Also, having Apache made it easier to set up my letsencrypt certificate, because I can't find the appropriate documentation for the website module in odoo.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
RSS

Powered by phpBB® Forum Software © phpBB Group