Linode Forum
Linode Community Forums
 FAQFAQ    SearchSearch    MembersMembers      Register Register 
 LoginLogin 

Post new topic Reply to topic
Author Message
PostPosted: Wed May 19, 2010 1:42 pm 
Offline
Junior Member
User avatar

Joined: Thu Apr 29, 2010 3:32 pm
Posts: 44
Location: Oregon
I have two nodes initially configured as LAMP nodes. The first node is now a web server only and the second is a database server and mail server only. Both nodes are Ubuntu 10.04 LTS.

My question is now that I have MySQL running on node two as a remote database server (via private IP), how do I prevent MySQL on node one from starting up during boot? I don't want to uninstall MySQL on node one and I don't want to make other drastic changes in case I want to bring up MySQL again on node one.

If MySQL was part of the traditional runlevels I could just
Code:
update-rc.d mysql disable
but when I do that now I get
Code:
update-rc.d: warning: /etc/init.d/mysql missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
 System start/stop links for /etc/init.d/mysql do not exist.


Investigating I find a "mysql.conf" in /etc/init. However there is a link "mysql -> /lib/init/upstart-job" in /etc/init.d, so I'm confused.

Do I edit /etc/init/mysql.conf or remove it? And if I edit it, what do I comment out or put in its place?

Or can I just remove the link in /etc/init.d to prevent startup during boot and leave mysql.conf alone?


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 19, 2010 1:48 pm 
Offline
Linode Staff
User avatar

Joined: Sat Jun 21, 2003 2:21 pm
Posts: 160
Location: Absecon, NJ
Unfortunately, update-rc.d doesn't know how to handle Upstart's files so it doesn't work for disabling things. If you're on Lucid, I think you can simply rename /etc/init/mysql.conf to /etc/init/mysql.conf.disabled. If you're on an earlier Ubuntu I think the only non-destructive way to disable jobs in /etc/init is to create an /etc/init.disabled directory and move them there.

-James


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 19, 2010 1:58 pm 
Offline
Junior Member
User avatar

Joined: Thu Apr 29, 2010 3:32 pm
Posts: 44
Location: Oregon
Yeah, I'm on Ubuntu 10.04 LTS (Lucid Lynx).

I'll try the rename to .disabled as you suggested, thanks!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic


Who is online

Users browsing this forum: Guspaz and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
RSS
Powered by phpBB® Forum Software © phpBB Group

Home | Manager | Contact Us | Jobs | Terms of Service | Privacy Policy | ™ © 2003-2012 Linode, LLC. All rights reserved.